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History 

Revision Update Information 

1.0 Initial document release for Version 21.1  

2.0 Updated following the bug fixes implemented to resolve the issue of 
interactively exporting JT data from within CATIA using a selected 
Configuration file. CD link updated to download updated install 
CAD_21.1_CA5JT_WIN.03 

  

  



PRODUCT RELEASE ANNOUNCEMENT 

3 | P a g e   ©Theorem Solutions 2018 

Product Codes 

Product Code Product Description 

CA5JT-U1 CATIA V5 (CAA Based) to JT (uni-directional) 

JTCA5-U1 JT to CATIA V5 (CAA Based ) (uni-directional)                                                  

CA5JT-A5 CATIA V5 (CAA Based ) to JT (uni-directional) with PMI Add On 

CA5JT-A6 CATIA V5 (CAA Based ) to JT (uni-directional) with Electrical Add On 

CA5JT-A7 CATIA V5 (CAA Based ) to JT (uni-directional) with 3D PDF Add On 

JTCA5-A1 JT to CATIA V5 (CAA Based ) (uni-directional) with 3DPDF Add On 

JTCA5-A2 JT to CATIA V5 (CAA Based ) (uni-directional) with 3DXML Export Module 

CATJT-U1 CATIA V4 to JT (uni-directional) 

CAGJT-U1 Combined CATIA V4 & CATIA V5 to JT (uni-directional) 

CAGJT-U2 Combined CATIA V4 & CATIA V5 to JT (uni-directional) with PMI Add On 
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Supported Application Revisions 

The following application revisions have been qualified with this release    

Application Revision 

CATIA V4 All revisions 
CATIA V5 CATIA V5-6R2015, CATIA V5-6R2016, CATIA V5-6R2017 & CATIA V5-

6R2018 
JTOpen JTK 9.0.0.0 

 
Supported Operating Systems 
The following operating systems have been qualified with this release    

Operating System Qualification Status 

Windows 7 64bit Qualified and fully supported (All CATIA Revisions) 

Window 8 64bit Qualified and fully supported for CATIA V4, CATIA V5-6R2015, CATIA 
V5-6R2016, CATIA V5-6R2017 & CATIA V5-6R2018 

Windows Server 
2008 R2 

Qualified and fully supported for CATIA V4, CATIA V5-6R2015, CATIA 
V5-6R2016, CATIA V5-6R2017 & CATIA V5-6R2018 

Windows Server 
2012 

Qualified and fully supported for CATIA V4, CATIA V5-6R2015, CATIA 
V5-6R2016, CATIA V5-6R2017 & CATIA V5-6R2018 

Window 10 64bit Qualified and fully supported for CATIA V4, V5-6R2016, CATIA V5-
6R2017 & V5-62018.  
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Installation Process Considerations 

Starting with version 20.0 of Theorem Solutions applications changes have been made to the 
installation process. These changes have transitioned from a JAVA based installer package to 
a standard Microsoft Installer (.msi) package. A current limitation of the Microsoft msi 
method is that the software cannot be installed directly on to either externally mapped or 
network drives when installed from a client machine:  

 

Therefore, the installation must be performed to a drive that is local to the machine itself. 

If you are attempting to install the software onto a network drive, then please refer to the 
configuration guide available from the following link 
http://www.theorem.com/documentation/Documentation/Client_Configuration.pdf. 

Distribution Media 

CD images of the latest release are available from the following download site. The 
installation media for the bi-directional product is also the same media when installing a uni-
directional variant.   

Product Codes Select link to download CD images 

All Product Codes for all 
supported versions of CATIA V5 

https://s3-eu-west-
1.amazonaws.com/theorem.software/CADverter_21.
1/CAD_21.1_CA5JT_WIN.03.msi 

Related Distribution Media 

In addition to the translator software itself there are also two other related media 
distributions available. One is for the installation and configuration of the Theorem User 
Interface. This is designed as a free-standing user interface for the translator allowing the 
user to navigate the file system and initiate translations either interactively or in batch using 
standard drag and drop techniques. The second media distribution contains the Theorem 
License Manager which is installed on the nominated license server(s) and manages the user 
access to the purchased volume of concurrent Theorem application licenses.  

 

 

http://www.theorem.com/documentation/Documentation/Client_Configuration.pdf
https://s3-eu-west-1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_CA5JT_WIN.03.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_CA5JT_WIN.03.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_CA5JT_WIN.03.msi
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Related Package URL for CD image download 

Theorem User 
Interface 

https://s3-eu-west-
1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_UI
_WIN.01.msi 

Theorem License 
Manager 

https://s3-eu-west-
1.amazonaws.com/theorem.software/LicenseManager/CAD_FLEXLM
_11.14_WIN.01.msi 

 
 

  

https://s3-eu-west-1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_UI_WIN.01.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_UI_WIN.01.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/CADverter_21.1/CAD_21.1_UI_WIN.01.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/LicenseManager/CAD_FLEXLM_11.14_WIN.01.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/LicenseManager/CAD_FLEXLM_11.14_WIN.01.msi
https://s3-eu-west-1.amazonaws.com/theorem.software/LicenseManager/CAD_FLEXLM_11.14_WIN.01.msi
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New Features / Enhancements 

The following new features or enhancements have been introduced with this release  

CATIA V5 to JT (CA5JT) 

Ref ID New Feature / Enhancement Description 

1 Support for CATIA V5-6R2018 has been implemented with this release 

2 

The default JT configuration file is now named tess.config. The structure of 
this file is such that it now supports all variants of CAD to JT translator 
requirements. The sections of the file that are relevant to the CATIA V5 to 
JT translator are; JtOptions (for all Theorem related settings that influence 
the JT output), Catia5Options (for all Theorem related CATIA V5 data read 
settings), Catia4Options ( used to control the processing of any 
subordinate CATIA V4 native .model files) & GeneralOptions (used to 
select any general output processing requirements)  

3 
When writing JT output the assembly representation can now be written 
as either STEP AP242 BOM Edition 1 or STEP AP242 BOM Edition 1-TC 
(Technical Corrigendum) format 

4 

The option to control the JT instance names based upon the CATIA V5 
Node Customization settings now support the enhancement to allow the 
use of User Defined attributes as part of the output naming. There are two 
methods available; 
When setting the customization within CATIA V5 and therefore the setting 
is stored within the active users CATSettings use the options 
use_instance_names instance_naming V5. Alternatively you can specifiy 
the specific insnace naming convention on the command line using a 
combination of system settings and user attribute values e.g. 
use_instance_names instance_naming “#PN# #@ATTR_NAME@#” where 
ATTR_NAME would be the specific attribute name available within the 
CATIA V5 data 

5 

There is a new menu page available from the CATIA V5 menus 
Tools>Options>Infrastructure>Theorem>CAA Export JT. This allows the 
selection of a predefined CADverter Configuration page to control the 
exporting of JT data from within the CATIA V5 environment. There are two 
mechanisms available for creating CADverter Configurations. One is to use 
the CADverter Unified Interface, another is the use of the Configuration 
Manager Interface. 

6 
JT files can now be directly exported from within CATIA V5 using the 
File>SaveAs menu and selecting the JT file format. The settings of the JT 
export process are defined using the currently selected CADverter 
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Configuration defined in the Tools>Options>Infrastructure>Theorem>CAA 
Export JT menu 

7 

Changes to the method of defining the JT entity “moniker” from the CATIA 
V5 Face ID# to the CATIA V5 Underlying Surface ID#. This change maintains 
the JT entity “moniker” for iterations of the CATIA V5 model and 
subsequent sequential JT file exports 

8 
By default CATIA V5 System and User Properties are now automatically 
exported. To disable this feature use the option attr_off 

9 

When exporting CATIA V5 data to JT the exporting of the CATIA V5 
properties has been enhanced by using a default property mapping table, 
%TS_INST%\data\jt_property_mapping.txt. This facility allows the user to 
control which properties are exported and also enables the property name 
to be modified as part of the export process. 

10 
The labels for the system defined JT Properties have been modified to 
match the ProSTEP Recommended Parctices for JT property names.  

11 

The Large Assembly Processing mechanism has been enhanced to include 
the ability to write the JT data using either PER_PART, PLMXML or 
STEP_BOM format output in addition to the previously supported 
FULL_SHATTER method  

 

JT to CATIA V5 (JTCA5) 

Ref ID New Feature / Enhancement Description 

1 Support for CATIA V5-6R2018 has been implemented with this release 

2 

The progress file output generated when reading JT files to create CATIA V5 
output previously reported all of the JT attributes as part of the file 
processing. Although this output may be beneficial when trying to investigate 
a translation issue in the majority of cases the information is not required. 
Therefore, these properties are no longer recorded in the progress file unless 
the optional argument debug is used.  

3 
When reading JT datasets the translator is now able to read the assembly 
structure using either a STEP AP242 Edition 1 or STEP AP242 Edition 1-TC 
(Technical Corrigendum) format  

4  

When processing JT files to CGR output where the that JT data references 
empty JT parts the command line option create_empty_file will now create 
empty CGR files in the output. With previous releases the empty JT nodes 
where omitted from the output.  
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5 

There is a new menu page available from the CATIA V5 menus 
Tools>Options>Infrastructure>Theorem>CAA Import JT. This allows the 
selection of a predefined CADverter Configuration page to control the 
importing of JT data from within the CATIA V5 environment. There are two 
mechanisms available for creating CADverter Configurations. One is to use 
the CADverter Unified Interface, another is the use of the Configuration 
Manager Interface. 

6 

JT files can now be directly opened from within CATIA V5 using the File>Open 
menu and selecting the JT file format. The settings of the JT import process 
are defined using the currently selected CADverter Configuration defined in 
the Tools>Options>Infrastructure>Theorem>CAA Import JT menu 

7 By default all JT Properties are now automatically exported. To disable this 
feature use the option attr_off 

8 When exporting JT data to CATIA V5 the exporting of the JT properties has 
been enhanced to enable the use a property mapping table. This facility 
allows the user to control which properties are exported and also enables the 
property name to be modified as part of the export process. To enable this 
feature use the option cad_prop_map_file followed by the name of the 
mapping file to be used. There is an example mapping file provided that 
documents the format and shows example settings  
%TS_INST%\data\jt_property_mapping.txt.  
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Known Limitations and Restrictions 

The following limitations and restrictions have been identified during final testing prior to 
release  

CATIA V5 to JT (CA5JT) 

Ref 
ID 

Limitations and Restrictions 

1 
The Theorem FLEXlm license manager for this release should be updated to the 
latest release available. See section on “Related Distribution Media”  

2 
When running a Large Assembly Process with FULL_SHATTER output format there is 
an erroneous error flagged raised at the end of the process. This normally can be 
ignored and the output will have been created correctly. 

 

JT to CATIA V5 (JTCA5) 

Ref 
ID 

Limitations and Restrictions 

1 
The Theorem FLEXlm license manager for this release should be updated to the 
latest release available. See section on “Related Distribution Media” 

2 

When processing JT assemblies that reference multiple occurrences of parts and the 
output mode is set to create CGR output each occurrence of the JT parts are created 
with unique CGR filenames. Each of the files will have a sequential number added to 
its name. To force the creation of single CGR files to represent every occurrence set 
the environment variable TS_CATIA_UNIQUE_CGR=1 prior to running the 
translator.  

 

General 

Ref 
ID 

Limitations and Restrictions 

1 

The ‘Theorem Help v21.1’ shortcut provided in the Windows Start Menu is 
incorrect. It currently looks for help.html in %Installation_Directory%/guides when 
the file is in %Installation_Direcotry%. 

This can be rectified by: 
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• Locate the Start Menu item (Theorem Help v21.1) 

• Right Click and then select Properties 

• In the ‘Target’ selection box, update the location to be "C:\Program 
Files\Theorem\21.1\help.html" 

• Select ‘Apply’ 
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Resolved Support Calls 

The following list of Support Calls are resolved with this release  

Support Call ID Brief Description 
CAS-03340-B6B6F8 JT to V5 translation crashing   

CAS-03387-F2L5B3 Missing dimension semantic properties for "27 x" dimension prefix 
text 

CAS-03404-Z4G0Z7 Processing CATIA V4 model with CATIA V5 to JT hangs during the 
CATIA read process 

CAS-03459-Z6M9M7 CATIA V5 to JT moniker ID's are not maintained when the model is 
subsequently changed 

CAS-03460-C5Y1B8 Large blocks of text are split into seperate blocks and the sequence 
of the text is reordered. 

CAS-03525-N1R2Z6 Unable to read PLMXML instance colours. This resolution requires 
the use of the create_occurrences option when processing data 
with instance related colours applied. 

CAS-03589-V7S5R4 Unable to interactively save JT output using tessDAIMLER.config 

CAS-03682-M3B2W6 Unable to use existing configuration files following upgrade to 21.1 
release when saving JT data interactively 
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